Page 1 of 1

Program fails to run when Unmanaged Tracker enabled

Posted: Wed Oct 31, 2007 10:37 pm
by IntelliServ
I have a program that uses a 3rd party OpenGL wrapper/control (in C#). I sometimes get a GL_OUT_OF_MEMORY error from this control. I have noticed that when this happens Process Explorer says that the working set is just over 300 MB but the Virtual Memory Size is just under 2 GB. I want to see what the unmanaged memory is doing so I tried running with the unmanaged memory tracker enabled. When I do this my program freezes before the window displays. If I take out the OpenGL component and run with the unmanaged memory tracker enabled then it works just fine. Also, if I run my program with the OpenGL component but without the unmanaged memory tracker then it works just fine. Is there anything that I can do to get the unmanaged memory tracker to work with the stuff I need to watch?

Thank you for your time.

Posted: Thu Nov 01, 2007 6:19 pm
by Andreas Suurkuusk
From your description there seems to be some problem with using the resource tracker together with OpenGL (or the 3rd part OpenGL wrapper).

To solve this problem it would be good if we could reproduce the problem ourselves. Is the problem reproducible using a simple OpenGL application using the wrapper? Is the third party OpenGL wrapper available for download (e.g. is there an evaluation version available)?