.Net memory Profiler Tool does not start Profiling for ASP

Use this forum for questions on how to use .NET Memory Profiler and how to analyse memory usage.
Post Reply
dineshkumar
Posts: 1
Joined: Sun Jan 27, 2008 7:54 am

.Net memory Profiler Tool does not start Profiling for ASP

Post by dineshkumar » Sun Jan 27, 2008 8:02 am

Hi,

I am evaluting this .Net Memory profiler Tool.
Pls find the details of the environment.

1) OS : Windows2000 Server
2) Webserver : IIS5.0
3) Installed : .Net2.0 Framework
4) Technology : ASP pages
5) .Net profiler Version : 3.0

I had Successfully installed the .Net Profilier 3.0 Tool in my Application server. When I tried to Start the profilier using ASP.Net Web application and mentioned the Address of the application url. it not starting. It is showing the following error message,

"Waiting for profiled process to start"

Even after manually opening the application url in the browser, the profiling tool doesnot starts.

Pls let me know, do i missing some configuration settings in the tool or any other reason.

Our organisation would like to buy this tool if this successfully evaluated.

Regards
Dinesh

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Post by Andreas Suurkuusk » Mon Jan 28, 2008 8:32 pm

.NET Memory Profiler should be able to profile an ASP.NET application using the configuration you have.

You need to run under an administrative account in order to profile an ASP.NET application using IIS, and the web application must run on the local machine. As soon as the .NET runtime is loaded by the ASP.NET worker process, the "Waiting for profiled process to start" message should disappear.

I just tested profiling ASP.NET using a configuration similar to yours, but I could not find any problems. Could you provide some additional information about your configuration? Are you running the application using impersonation? Are you able to profile other types of processes (e.g., a standalone .NET application, or ASP.NET using WebDev.WebServer)?
Best regards,

Andreas Suurkuusk
SciTech Software AB

azul
Posts: 3
Joined: Mon Mar 03, 2008 10:50 am

Post by azul » Mon Mar 03, 2008 11:04 am

Hi,

Maybe I will bump this topic as Im also having problem with starting profiling ASP.NET application.

The problem is that I cannt to start profile ASP.NET application on WebDev server.
It does not matter if I start it from VS or from .net profiler executable, effect is completly the same.

Problem is that the .net profiler automaticly set up a port on WebDev server under which the application is not aviable.

Lets make an example:
I have an application named: TestProject (its an web application , not a website).
Its located on drive C:\Test\TestProject\

In project settings of TestProject I have setup that I use VS Development Server (Auto-assign port and Virtual path: "TestApp" <- very important).

And the problem now:
When I want to start profiling the application while setting up , ok I set "Launch using WebDev.WebServer" , i specify path: "C:\Test\TestProject\"

"What page should be requested to start the ASP.NET application":
http://<webdev>/TestApp/test.aspx

and boom, it does not work.
.NET profiler takes a random port at which application is not aviable,
so lets say application is aviable on port: 1900, so local address would be
http://localhost:1900/TestApp/test.aspx

while .net profiler try to search for
http://localhost:XXXX/TestApp/test.aspx
where XXXX - is random port u cannt setup anywhere.

so question is how to bypass it, or how to setup the webdev port either in .net profiler or VS (i can setup specific port on web application but is it the way to go ? )

Im lisenced user also.

azul
Posts: 3
Joined: Mon Mar 03, 2008 10:50 am

Post by azul » Mon Mar 03, 2008 12:57 pm

ok found where the actual problem was.
It was in virtual path.
port does not have anything to do with it.
Problem is that you have to have identical virtual directory set on your web application as the folder where you have application else it simply wont work
example:
"C:\Test\TestProject\"

you need to specify as virtual directory: "/TestProject"
whats even worse it does not take your "Specific page" from "Page action".
Its major overlook imo.
My opinion is that if you dont specify a page in virtual directory then take one from your web application settings (and those are as i know user specific).
It bad that you cannt specify virtual directory under which application works. You can write something in
"What page should be requested to start the ASP.NET application":
but as i seen on ASP.NEt Dev Server its still your folder where application is and not what you have specified.

Using .net profiler 3.1.271.0

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Post by Andreas Suurkuusk » Mon Mar 03, 2008 10:17 pm

When the profiler starts profiling an ASP.NET application using the Developer Webserver (WebDev.Webserver), it is launched using the default settings of Visual Studio:

- Virtual directory: set to directory name of project
- Port: random

To view a page from the development server, the URL http://<webdev>/VirtualDir/page.aspx should be used. Note that http://<webdev> will be replaced with http://localhost:port.

How do you specify the Virtual directory and port of the server? Do you use the Developer Web Server Properties introduced in Visual Studio 2005 SP1/VS 2008? The current release of .NET Memory Profiler does not make use of those properties. We will make use of them in the next version (or probably already in a maintenance release). We will also make it possible to specify the virtual directory and port of the web server when using the "Profile ASP.NET" command.

When the application is started from Visual Studio and a specific start page is assigned, we always use the specified page. Doesn't this work for you? If no start page is specified, we open the default page, or, if you start profiling by right-clicking a page, the selected page is started.
Best regards,

Andreas Suurkuusk
SciTech Software AB

azul
Posts: 3
Joined: Mon Mar 03, 2008 10:50 am

Post by azul » Tue Mar 04, 2008 8:58 am

Its correct that the .Net memory profiler uses the project name as virtual directory but the actuall virtual directory on "production server" may not corespond to the project name and in .Net memory profiler you dont have a chance to specify somewhere (in configuration of the starting ASP.NET profiling settings) the virtual directory on which it should run.

As i said in previouse example:
Project name: "TestProject"
Virtual directory (lets say from "production server"): "TestApplication".

You cannt make .Net memory profiler to run on those settings because you cannt specify explicit virtual directory.

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Post by Andreas Suurkuusk » Tue Mar 04, 2008 2:38 pm

You are correct. It would be good if it was possible to specify the virtual directory when using the Developer Web Server. I have added it as feature request for .NET Memory Profiler 3.1 and it will be included in a maintenance release of this version.
Best regards,

Andreas Suurkuusk
SciTech Software AB

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Post by Andreas Suurkuusk » Thu Mar 06, 2008 2:02 pm

We have now released a maintenance release of .NET Memory Profiler 3.1. This release adds the possibility to specify the virtual path of the development web server, as well as the port the server should listen to. It can be downloaded from http://memprofiler.com/download.aspx.
Best regards,

Andreas Suurkuusk
SciTech Software AB

Post Reply

Who is online

Users browsing this forum: No registered users and 26 guests