Profiling under Windows 7 does not work

Use this forum for questions on how to use .NET Memory Profiler and how to analyse memory usage.
Post Reply
magnus
Posts: 3
Joined: Mon Mar 23, 2009 2:16 pm

Profiling under Windows 7 does not work

Post by magnus » Mon Mar 23, 2009 2:21 pm

Hello,

I'm using you GameOfLife sample, I used the original compiled application and then I also tried recompiling it with VS 2008 ... anyhow what is happening is that the target application is started but the profiler continues displaying the dialog box stating that the profiler is waiting for the application to start.

Is there any workaround to solve this issue?

Thanks.

S.

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Post by Andreas Suurkuusk » Mon Mar 23, 2009 8:49 pm

We have only tested .NET Memory Profiler with the 32-bit version of Windows 7, but we have not been able to notice any problems. If the dialog box doesn't disappear when starting the profiling, the profiler has not been loaded into the profiled process. One reason for this could be that there is a problem with the registration of the profiler. Can you try to uninstall the profiler, restart the computer and then reinstall it?

if the runtime fails to load the profiler library, there might also be an event in the event viewer. Do you see any runtime related events in the Event viewer?
Best regards,

Andreas Suurkuusk
SciTech Software AB

magnus
Posts: 3
Joined: Mon Mar 23, 2009 2:16 pm

Post by magnus » Wed Mar 25, 2009 6:07 pm

.NET Runtime version 2.0.50727.3521 - Failed to CoCreate profiler.

magnus
Posts: 3
Joined: Mon Mar 23, 2009 2:16 pm

Post by magnus » Wed Mar 25, 2009 6:16 pm

Uninstalled and reinstalled, problem still there. I'm running as the administrator user on the machine and yes, I'm running Windows 7 32-bit.

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Post by Andreas Suurkuusk » Thu Mar 26, 2009 3:14 pm

I have run several more tests under Windows 7, using the Game of life tutorial application and Visual Studio 2008. And I have not been able to see any problems.

However, one possible explanation is that there's a problem with the license registration of the profiler. Can you try to run the profiler as the administrator (by clicking "Run as administrator") and then enter your registration key again (using "Help->Enter Registration Key"). If you are evaluating the profiler and don't have a registration key, please contact us at support@scitech.se, and we will provide you with a evaluation extension key that you can use.
Best regards,

Andreas Suurkuusk
SciTech Software AB

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests