Resource Details tab shows Skipped Frame(s)

Use this forum for questions on how to use .NET Memory Profiler and how to analyse memory usage.
Post Reply
mcohen75
Posts: 2
Joined: Thu Nov 11, 2010 4:47 pm

Resource Details tab shows Skipped Frame(s)

Post by mcohen75 » Sat Nov 13, 2010 4:30 pm

When I drill down to the Kernel-VirtualMemoroy resource, many of the callstacks show skipped frames.

Here's an example:
ntdll!NtAllocateVirtualMemory( HANDLE, PVOID*, ULONG, PULONG, ULONG, ULONG )
[Skipped frame(s)]
mscorwks!EnsureEEStarted( enum tagCOINITEE )
mscorwks!_CorExeMain()
[Skipped frame(s)]
ntdll!RtlUserThreadStart()

I've set the download from MS symbol server option, turned off stack reducer and I have the unmanaged resources tracker turned on. I'm using a project and have verified that the settings are the same on the project.

I'm using version 3.5.162 of .NET Memory Profiler x64.

With these settings, shouldn't I see the skipped frames?

Thanks,
Mike

Andreas Suurkuusk
Posts: 1029
Joined: Wed Mar 02, 2005 7:53 pm

Re: Resource Details tab shows Skipped Frame(s)

Post by Andreas Suurkuusk » Sun Nov 14, 2010 10:29 pm

If you have disabled the call stack reducer, you should not see any [Skipped frames] (even though you may still see [Unidentified frames]). How did you disable the call stack reducer? If you used the Tools->Options command, you will only change the default settings. These settings will not take effect until you start a new profiling session from scratch, i.e. using "Profile Application" instead of just the "Profile->Start" command. To change the settings of the active session, use the "View->Session Property Pages" command instead. Note that call stack reducer cannot be disabled while profiling, only between profiling sessions.

If you have correctly disabled the call stack reducer, please contact us again so that we can investigate this problem further.
Best regards,

Andreas Suurkuusk
SciTech Software AB

Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests