Page 1 of 1

"Waiting for profileid process to start." never goes away

Posted: Thu May 12, 2011 5:52 pm
by Jerky Boy
Hey guys - I hope I'm posting this in the correct forum...
I'm evaluating ver 4.0 and trying to investigate memory leaks in IIS. I choose WIndows Service, select WWW service, and recieve a dialog stating "Waiting for profileid process to start". The message never goes away, and I don't see anything in task manager about profileid. What gives?

Any help would be appreciated.

Re: "Waiting for profileid process to start." never goes awa

Posted: Fri May 13, 2011 3:58 pm
by Andreas Suurkuusk
The "Waiting for profiled process to start" message will disappear when the .NET runtime has been started in the profiled process and the profiler callback library has been loaded. In your case I believe the runtime will not be started by the WWW service, but rather by a separate worker process. To profile IIS, I recommend that you select the profile ASP.NET option and then choose to use IIS. This will make sure that the profiler connects to the IIS worker process.

Re: "Waiting for profileid process to start." never goes awa

Posted: Tue Jun 05, 2012 6:40 pm
by tuanpm
Hi,
I have received "Waiting for profileid process to start" message never done too.( i selected the profile ASP.NET option and then choose to use IIS)
May you help me? thanks

Re: "Waiting for profileid process to start." never goes awa

Posted: Wed Jun 13, 2012 8:14 am
by Andreas Suurkuusk
In order for the "Waiting for profiled process" message to disappear, the .NET runtime must have been loaded into the process. For ASP.NET profiling using IIS, this normally occurs when you request the first ASP.NET page. For some troubleshooting information about this problem, take a look at
this forum post.