Unable to profile WCF Service in IIS using nmpcore

Use this forum for questions on how to use .NET Memory Profiler and how to analyse memory usage.
Post Reply
aaronmell
Posts: 2
Joined: Mon May 05, 2014 2:18 pm

Unable to profile WCF Service in IIS using nmpcore

Post by aaronmell » Mon May 05, 2014 2:39 pm

Having an issue using nmpcore and trying to profile a WCF service in IIS. When I run nmpcore It never gets past waiting for the .net run time to be loaded screen. I've been able to successfully profile our client application running on IIS on a different machine, so I am not sure what the issue might be

Its a standard WCF service, running IIs 7.5 under the default web site. Its running under .Net 4.0, and I am using nmpcore 4.6.66

aaronmell
Posts: 2
Joined: Mon May 05, 2014 2:18 pm

Re: Unable to profile WCF Service in IIS using nmpcore

Post by aaronmell » Mon May 05, 2014 3:50 pm

I think I was able to resolve the issue. We are running the application pool under 32 bit mode. Turning this off and the profiler picked up that the service was running

Andreas Suurkuusk
Posts: 1005
Joined: Wed Mar 02, 2005 7:53 pm

Re: Unable to profile WCF Service in IIS using nmpcore

Post by Andreas Suurkuusk » Tue May 06, 2014 2:37 pm

You are correct, it seems like it is not possible to profile a WCF service running under IIS when the 32-bit mode is enabled on a 64-bit OS.We will look into this and see if it something we are able to correct.
Best regards,

Andreas Suurkuusk
SciTech Software AB

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest