Failed to locate WebDev.WebServer to profile using v5.0

Use this forum for questions on how to use .NET Memory Profiler and how to analyse memory usage.
Post Reply
wsimington
Posts: 1
Joined: Fri Jun 26, 2015 5:07 pm

Failed to locate WebDev.WebServer to profile using v5.0

Post by wsimington » Fri Jun 26, 2015 5:27 pm

Hello,

I am trying to profile an ASP.NET MVC application with v5.0.80.0 of the .NET Memory Profiler. When attempting to profile from either Visual Studio 2013 or the standalone application, I get the following message:

The operation failed with the following error: Failed to locate WebDev.WebServer.

The application is being hosted from IIS on that server without issue. The server in question is Windows 2012 R2 Standard running on a VMWare virtual machine. Any ideas?


Thank you,

Warren Simington

Andreas Suurkuusk
Posts: 1000
Joined: Wed Mar 02, 2005 7:53 pm

Re: Failed to locate WebDev.WebServer to profile using v5.0

Post by Andreas Suurkuusk » Mon Jun 29, 2015 7:42 pm

How do you start profiling your ASP.NET application? WebDev.WebServer is only included with the installation of Visual Studio 2012 and earlier.

If you have an ASP.NET application written using Visual Studio 2013 I recommend that you start it using IIS Express or IIS. I also recommend that you download version 5.0.98 which was released recently. This version includes significant improvements over 5.0.80 and some changes in how ASP.NET profiling is started.
Best regards,

Andreas Suurkuusk
SciTech Software AB

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 8 guests