Page 1 of 1

No .Net runtime in dump file?

Posted: Mon Apr 09, 2018 10:48 am
by Harag

My trial has expired, but I'm loving the product, and purchased it this morning. :)

As I'm still learning about memory dumps and looking at the data I'm a little stumped at this error message. One of our clients were having issues, so I thought I would ask for a memory dump from them - they opened task manger, rightclicked on the application and selected "Create Memory Dump", they then sent this file to me - 1.5 GB in size.

Opening the .DMP file in Visual Studio 2017 worked just fine, I had no issues. However when I try to open this dmp file with .net memory profiler I get this error:

"The operation failed with the following error: No .NET runtime found in the process"

before I got this error it was having trouble finding a dll (mscordacwks.dll) on the MS symbol servers - looking at the version of the dll it was asking about (and some googling) I found that this file is a Silverlight v5 dll and the file could be found in "C:\Program Files (x86)\Microsoft Silverlight\5.1.50907.0" however the file wasn't in there - I selected "mscorlib.dll" by accident from that folder, and since then I have been getting the above error message and no prompt for the dll.

So how can I analyse this DMP file in the application (and not VS2017), and in future, how do I get actual dump files from clients that will work?

Doing the above "Task manager > Create Dump File" worked when I did this on my Local PC with no issues.

Many thanks for any help / pointers about this.


Edit 1: Just found this like - ... pfiles.htm
The screen shot on that page about the ".net data access library" is the one I'm talking about. After selecting an invalid file at this point, I'm no longer getting the prompt but it comes up with the error message I mentioned above "No .NET runtime found in the process". How can I reset it to prompt me for the file?

Edit 2: I searched the clients machine at the silverlight folder mentioned, and that file doesn't even exist there. Currently no idea where to get the file from, can't find it via googling either.

Re: No .Net runtime in dump file?

Posted: Tue Apr 10, 2018 1:30 pm
by Andreas Suurkuusk
It seems like you have encountered a bug in the retrieval of the data access library. If an incorrect data access library file is selected, but the version (and platform) of the file is exactly the same as the expected library file, then the profiler will not prompt for the file again (unless another memory dump file is imported). We have now fixed this error. You can download the fixed version from: ... 5_6_29.exe

Since Silverlight has been deprecated by Microsoft, we have not updated the support for Silverlight in the most recent version and we're not testing the profiler with Silverlight. However, Silverlight profiling should still work correctly.

The data access library for Silverlight is named mscordaccore.dll (and not mscordacwks.dll). If you copy this library from the client machine, the import should hopefully work better.

Re: No .Net runtime in dump file?

Posted: Wed Apr 11, 2018 9:00 am
by Harag
Hi Andreas

Many thanks for the new version, I've installed this and tried to import the DMP file, it's now prompting me for the .net data access library again.
.Net Data Access Library not found
I've never really used silverlight, but I know it's been depreciated. Checking my own PC I do appear to have silverlight installed in the following location (not sure why, I never use IE):

C:\Program Files\Microsoft Silverlight\5.1.50907.0

So I've looked in that folder (and also done a search on my windows file for both the file it mentions in the screenshot, and the one you mention (mscordaccore.dll), but don't appear to have either of these. I'll ask the client to see if they can find this other file on their machine.

The dmp file does however open up in VS 2017 fine and I've managed to find what I needed from the dmp file via that, but it's no where near as easy to use as your app :)

Thanks again for the help, and glad I found a bug for you!

Re: No .Net runtime in dump file?

Posted: Wed Apr 11, 2018 1:00 pm
by Andreas Suurkuusk
It's strange that you don't have the "mscordaccore.dll" on your system. It should be part of the Silverlight installation. Maybe you don't have a full installation of Silverlight? Maybe "C:\Program Files\Microsoft Silverlight\5.1.50907.0" is just a left-over directory?

If you get the file from the client, the import will hopefully work. But as I mentioned, Silverlight has been depracated and we're also deprecating the support for Silverlight in the profiler. However, if I find the time I will do some Silverlight tests and see if it works correctly. If not, and if it's not too much work, we will make sure that it works in a future maintenance release.

Re: No .Net runtime in dump file?

Posted: Wed Apr 11, 2018 4:02 pm
by Harag
The folder:

C:\Program Files (x86)\Microsoft Silverlight\5.1.50907.0

is about 40.4 MB in size with 202 files and 40 folders. the file isn't in there at all

However, with the new version you sent me, I get the same prompt asking for the file, but if I click CANCEL this time, it seems to go ahead and import the memory dump. I don't think it did that in the previous version. No sure what affect this has on the data, but it looks ok to me...